Welcome to the DeFi Saver knowledge base.

What are the requirements for using Automation?

Written by Nikola Jankovic
Updated 3 months ago
  • There are currently two requirements needed for enabling Automation.

    Firstly, the user’s position needs to be on a Smart Wallet. This is already the default behaviour in MakerDAO and Reflexer (as the Smart Wallet is in fact the standard MakerDAO dsproxy), while any Compound and Aave users that wish to use Automation would need to import their position to their Smart Wallet first.

    Secondly, there is a minimum debt requirement for enabling Automation. This is something that was introduced as a way to protect both the users and system from extremely high gas prices and transaction costs, especially during market crashes. The result of gas price spikes to 1,000-2,000+ Gwei during market crashes have historically been both amplified losses for users, as well as losses for the system.

    Currently, the minimum debt requirements are:
    • 40,000 Dai debt for MakerDAO
    • $60,000 in total debt balance for Compound and Aave v2
Did this answer your question?